
EFFECTIVE PROJECT MANAGEMENT USING MINDGENIUS

What is Project Management?
Project Management is the science of managing a one-off project through to conclusion.  This requires the setting of a
plan, breaking the overall project down into individual, more manageable tasks (with start and finish dates, costs,
resources and durations for each task), and monitoring and reacting to any deviations from the plan.

Traditional Approach
Software tools such as MS Project are often used to produce and maintain a project plan.  However, when it comes to
collating the ideas and information that are fundamental to scoping the work involved in a project, and to designing an
effective project plan, traditionally flip charts or white boards are the only tools available.

Such idea gathering typically runs into many pages, all of which need to be pored over in detail in order to be properly
interpreted and understood.  This is an extremely arduous task that can take weeks to conclude.   As a result, project
plans often fail before they are even implemented, due to the lack of planning, preparation and consideration of all
relevant information at the outset.

This problem, as we will show, is overcome totally with MindGenius.

Project Management with MindGenius
Project Management with MindGenius becomes simple and straightforward.   To begin scoping and designing your project
properly, you need only a meeting room with computer projection capability and a PC with MindGenius installed.

The project scoping session will require a facilitator to ensure that all areas are covered thoroughly and given equal
weight, and ideally a scribe to type the thinking directly into MindGenius.

If a scribe were not available, the facilitator would typically log the thinking him or herself.  Typical questions used by a
facilitator are available by viewing the Project Management sample map directly from the Help menu.

Effectively managing a project, from the initial thinking stage through to project close, requires both MindGenius business
and Microsoft Project installed on your own desktop, and those of the project team.   MindGenius can be used to great
effect at all stages of project management.  To find out more, read on.

We all have tasks to perform on a daily basis. When the tasks interrelate to each other and combine to achieve an overall
end objective, we are involved in a project. There is a wealth of knowledge and experience contained in volumes of books
on project management, lots of 400+ page tomes. Yet in practice, many project management approaches used are often
erratic, ineffective, and incomplete. 



MindGenius can help you manage projects more effectively if you follow a process such as the one shown below:

1. Scope - What has to be achieved? What is the scope of the task? How will success be measured? What are
the risks and are they acceptable? What assumptions have been made and are they valid?
2. Plan - What specific activities need to be carried out to achieve the end objective? In what sequence must 
these tasks be carried out? Are there interdependencies between different tasks? Who is responsible for these
tasks? What resources are required? When do the tasks have to be completed by? Communicate plan and 
allocate tasks to the responsible people
3. Deliver - Carry out tasks. Have they been completed satisfactorily? Are there unforeseen challenges that 
require to be addressed?
4. Monitor - Understand where you actually are versus where the project plan says you should be. Are there 
changes to timescales, resource usage, budget, and deliverables that impact the project plan? What 
corrective/preventive actions need to take place in order for you to achieve the end objective?

To let you see how MindGenius can help you with the project management process, let's use the following scenario.

You are tasked with managing the company's presence at an exhibition 400 miles away in approximately 3 months time.

Now let's go through the project management process using MindGenius.

Step 1 - Scope
You need to have a clear vision of the purpose of the project. All too often people fall into the activity trap. They
immediately dive in and address the details of the specific activities that have to be carried out. Before you do this you
must be able to answer the following questions: 

• What has to be achieved? 
• What is the scope of the task? 
• How will success be measured? 
• What are the risks and are they acceptable? 
• What assumptions have been made and are they valid?

How can you dive into detail without knowing the answers to the above? Yet many people do so and are surprised when
their projects are late, over budget and do not deliver the desired benefits. 

MindGenius helps you address these questions.

The first step is to launch a new MindGenius map.  To do this:

1. Press the 'New' button       on the toolbar

When the map opens you will be prompted to enter a brief description of the subject matter. In this case, you would type
in "Exhibition project" which would overwrite the 'Map Diagram' text. 

Pressing 'OK' or the Return key results in the root branch
of the map being titled 'Exhibition Project'.

You can now use MindGenius to help you answer the
scoping questions.



MindGenius incorporates a special branch text entry method to minimise any intrusion into your thought process. Click
on any branch. You have now selected the branch (parent) to which you wish to add a sub-branch (child).  As you type
in the child branch title, the 'Add Branch' dialog will automatically appear in response to your keyed input. Continue typing
the title and press Return to add the branch.

You can continue to 'type-and-return' and more child branches will be added to the parent branch, or select a different
parent branch to add child branches to. 

Click on the root branch to select it, then type and enter the scoping questions. This will result in a map that looks as
follows:

The first step is to explore the scoping questions. So you click on a branch and start recording your thoughts using the
'type-and-return' method. 



You are just at the first stage and already your map has started to become complex - that's the nature of most practical
activities.



Your map has already grown in size and complexity. MindGenius has a Map Explorer feature that gives you powerful
navigation capabilities and allows you to 'walkthrough' your map and focus in on specific areas by drilling down.

Now you can explore the risks and ascertain whether or not they are acceptable. 

Not all of your risks have an equal probability. Some risks will be higher than others. You need to rank them e.g. high risk,
medium risk, low risk. MindGenius provides you with the capability of assigning key words (categories) to branches. You
can use them to visually indicate the likelihood of success and the likelihood of achieving the desired benefits.

Using the MindGenius categories you can assign the appropriate key word to a branch. In this case we will use the
following category symbols:

High Medium Low

Risk Factor



Your assessment of the risks may be as follows:

There will be a reason why you have selected specific ratings for the risks. You can add this detail, whilst preserving the
visual summary of your map, by inserting text as a note to a branch within your map.



In your risk assessment you have identified that there are two high risk areas - the booking of a stand at the exhibition
and the availability of a shipment company for the exhibition dates. These are high risk because they are outwith your
control and need to be resolved now if your project is to be successful. You need to take action.

MindGenius allows you to set a branch as an action, to allocate a named person to be responsible for the action and
assign specific dates against the action.



In this instance, let's focus on the 'Stand still bookable?' branch. Add a child branch and title it 'Book Exhibition stand'.
Assign the resource as 'Gordon Wyllie', who is responsible for procurement of exhibition space. Set the branch as an
action, with the action settings shown below:

Resources are applied in the same way as categories, i.e. select the Resource Tile, select a branch and double-click on
a resource. The initials of the resource applied will appear in the branch title. However, initially there will be no resources
in your Master Resource List. They can be quickly added in one of two ways:

1. Import the resources from your Outlook Contacts list:
a. Select 'Outlook Sharing', then 'Import Resources from Outlook'  from the File menu
b. Follow the simple wizard steps to import a list of resources

2. Add the resources manually to the Master Resource List:
a. From the Edit menu, select 'My Resources'
b. Using the dialog add new resources



After adding a note, assigning an action and resource, the contents of the three tiles should resemble the screen-shots
below:

Notes Editor  Resource Tile Action Tile

You can now assign the action on Gordon Wyllie by exporting it to Outlook.

To export actions to Outlook:

1. From the File menu, select 'Outlook Sharing' then 'Export Actions to Outlook'
2. Select 'OK' in the Export Options dialog, as the defaults are suitable

Exporting the action via Outlook will result in the following task appearing in Gordon Wyllie's Outlook task list:



Depending on your Outlook options, you may also have a copy of this task in your own task list.

You would complete your assessment of the risks and then verify whether or not your assumptions are valid or not. You
have assigned actions on tasks that have been identified as requiring urgent action. (When the actions are completed and
you get feedback on their outcome, you can update your risks and assumptions accordingly).

Having scoped the project, you are now clear as to what has to be achieved and how success will be measured. Save
your scoping map. You can now move on to the next stage in the process.



Step 2 - Plan
You now need to consider what specific activities need to be carried out to achieve the end objective and in what
sequence must these activities be carried out?

Create a new map and title it 'Exhibition project plan'.

You have already scoped the project and may need to refer to this information to keep you on track. MindGenius provides
you with the capability of attaching multiple electronic files to any branch.

1. From the Insert menu, select 'Attachment…'
2. Browse for the file to attach and press 'OK'
3. The attachment symbol (green paper-clip) will appear
next to the branch title. Double-click on this symbol
to open all attached files.

Browse for the Exhibition project map file that you previously saved, select it and
add it as an attachment to the root branch. Double-clicking on the Attachment
symbol will launch the scoping map in its native application (in this case
MindGenius).

You can now start to 'type-and-return' activities you think will be required to achieve the end objectives. You could simply
brainstorm your ideas around the root branch, but the preferred approach is to take a strategic view and progressively
drill down to specific activities. The concept of parent and child branches directly equates to the concept of summary tasks
and detail tasks.

Considering what you have to achieve then, the project could break down into four distinct stages:

• Gather equipment and material
• Construct Exhibition stand
• Support Exhibition stand
• Dismantle Exhibition stand

As you build your map it automatically structures. Each branch has a unique identifier, which indicates its position and
sequence in the hierarchy of the map. 

This equates to the Work Breakdown Structure (WBS) that you see in project plan

To display the numbers select
'Numbering' from the View menu.

In most project plans the tasks that require to be done first start at the left
hand side and the next tasks move in sequence from the left to the right.

Single file attachment

Multiple File attachment



MindGenius allows you to take different viewpoints of your map.

Select          to change your map into the Input Tree view.

So let's add some additional tasks exploring more specific levels of detail:



This Gantt chart has been derived directly from your map. MindGenius gives you the capability of transferring the contents
of your map directly into MS Project. To export to Project:

1. Select the Export to Project command         from the Export toolbar
2. The Export Options dialog will be presented.  Select 'OK' to continue as the default options are suitable
3. Project will open displaying your exported map as a Gantt chart



For the purposes of the
remainder of the document,
let's focus on the 'Pack Sales &
Marketing Material' activity.

If we continued to flesh out the
tasks associated with this
activity, your map will grow as
shown opposite.

Tips: If you are inserting a task then do

it in a Verb-Noun format. E.g., Place

contract.

If you are inserting a deliverable (or

milestone) then do it in a Noun-Verb

format. E.g. Contract placed.



To make the deliverables stand out from the
list of activities, assign a specific category to
them. 

This then allows you to use the MindGenius
filter function to query your map. 

In this case you can use it to identify what the deliverables are within the Pack Sales & Marketing material activity.



Filtering on the 'Deliverable' category results in the following map, where you can clearly identify the deliverables within
your project plan. This screenshot shows a filter where all non-matching branches are hidden where possible. To access
this option:

1. From the Tools menu select 'Filter' then 'Hide Non-Matching Branches'

Interdependencies will occur where the tasks are not in a straightforward sequence and you can identify linkages between
tasks that cut across your map structure.

You can identify such linkages using Mental Connections:

Having generated a map of the tasks you can now assign information to the branches to develop a plan with resources
and dates assigned. As you've already seen you can use MindGenius to assign resources and actions to branches.

For smaller, less complex projects you can manage your project from within MindGenius yourself. 

For larger, more complex maps we would suggest that you export your map to MS Project and edit the task
interdependencies and perform other more advanced project management tasks such as costing, PERT analysis,
resource levelling etc. within the MS Project environment. You can then create a new MindGenius map from the updated
MS Project file by importing the new file into MindGenius.  To do this:

1. From the File menu, select 'Import' then 'MS Project'
2. The Import from Project dialog will be presented



3. The main features transferred between MindGenius and MS Project, or vice versa are shown below:

4. Pressing 'OK' will import the file

From a Gantt chart, your project is transformed into a Map.

The plan can then be shared with others and any comments received can be incorporated if appropriate. When the plan
is approved it can then be communicated to project participants and appropriate actions assigned.

You can now proceed to the next step in the process.



Step 3 - Deliver
The people assigned can now proceed with addressing their tasks.

You can view the tasks that you have to carry out by filtering on yourself as a resource.

MindGenius also gives you the capabilities of looking at your maps from a different viewpoint. MindGenius will redraw
your map based on the categories that it contains or by the resources assigned to the branches.

To do this:

1. Finish applying categories and resources to the original map
2. From the View menu, select 'Create Category Map…' or 'Create Resource Map…' depending on your 
requirement

A resulting resource map is shown right.

Clearly in this instance, all of the tasks associated
with arranging the shipment details reside with
'Gordon Wyllie'.

A resulting category map is shown below.



You can see what tasks are completed and in progress. You can identify the deliverable that requires to be generated and
the 'red flagged' tasks - the ones that need the attention - are also evident.

To deliver your tasks you will also have to overcome challenges, some predefined, some unforeseen. MindGenius
provides you with the capability of implementing a wide range of methodologies and techniques to enable you to more
effectively complete the tasks that you have been assigned.

Other documents similar to this cover subjects such as:

• Brainstorming
• 6 Thinking Hats
• Mind Mapping
• Cause & Effect Analysis
• Solution & Effect Analysis
• Decision Making
• SWOT Analysis
• Meeting Management



Step 4 - Monitor
Progress against each task can be recorded within MindGenius. You can use the following features to provide status
information:

• Action Tile - You can include date changes, changes in priorities, % completion information.
• Notes Tile - Add a textual summary of the latest status against the task.
• Attachments - Link in supporting electronic information, e.g. test reports, trend graphs, checklists, fault 
analysis, budget spend, recovery plans.
• Categories - Visually identify specific aspects of progress against relevant branches.

Tip: Hovering the mouse over any of the symbols will show summary details about the symbol or icons' meaning.

With the branches of your map updated with the status you can then provide a progress report via a number of methods

Face- to -face review
• Use Map Explorer to walk through your project and communicate the status of the project to others.
• Use full screen mode {View}, {Full Screen} to maximise the screen area used for the map
• Filter the map to only show and discuss the status against any 'red flagged' tasks.
• Go into as much or as little detail as your audience requires to communicate the status and meet their needs
• Convert into an MS Project plan if they are more comfortable in that environment

Remote review
• Send as an e-mail attachment
• Package up your map and file attachments into a single file and send it as a file attachment 
• Send the MindGenius files along with a viewer so that they can view the files even though may not have 
MindGenius on their PC
• Save the maps as HTML files and people can access them and view them over the internet/intranet.
• Run MindGenius on web conferencing applications such as WebEx to communicate your maps to people in 
different geographical locations.

Any actions or comments identified can be recorded within your map and the actions issued to the responsible people
from within MindGenius. 



SUMMARY
MindGenius allows you to manage projects in a highly effective and practical way. It overcomes the operational difficulties
associated with the traditional way of thinking through, preparing, and managing projects.

By using MindGenius, effective project plans which lead to ownership, and therefore action, become the norm in an
organisation

Project Management - Scope, Plan, Deliver, Monitor - incorporates a common framework when working with MindGenius
as detailed below:

1. Information is GATHERED from a range of sources and people

2. This information goes through a process of being analysed and UNDERSTOOD before decisions are taken 
as what it means and how we progress forward

3. Our findings and recommendations from the Understand phase are BOUNCED off any colleagues who could
conceivably add value, by tapping into their collective knowledge, experience and creativity, and in doing so 
avoiding any difficulties encountered previously

4. Finally, with everyone in agreement on what needs to be done an action plan is produced to DELIVER the 
necessary components to ensure objectives are met

Sample maps explaining the gather, undertand, bounce and deliver  phases are available directly from the Help menu.
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